[gobolinux-users] Rox compile leads to ....

Rohan NIcholls rohan.nicholls at myrealbox.com
Thu Nov 11 01:53:02 GMT 2004


Again, more questions.

Has anyone managed to get Rox compiled? I have the recipe and
everything is happy.

I get this question during install:

Done
SandboxInstall: Installing ROX-Filer...
Testing the filer...
ROX-Filer 2.1.4
Copyright (C) 2003 Thomas Leonard.
ROX-Filer comes with ABSOLUTELY NO WARRANTY,
to the extent permitted by law.
You may redistribute copies of ROX-Filer
under the terms of the GNU General Public License.
For more information about these matters, see the file named COPYING.

Compiled with GTK version 2.4.1
Running with GTK version 2.4.1

-- features set at compile time --

Large File Support... Yes
GNOME-VFS library... No (need 2.8.0 or later)
Dnotify support... Yes
Binary compatibility... No (apsymbols.h not found)
The application directory will be:
        /Programs/ROX-Filer/snapshot/apps/ROX-Filer

The launcher script will be:
        /Programs/ROX-Filer/snapshot/bin/rox

Run actions will be in:
        /Programs/ROX-Filer/snapshot/share/Choices

MIME rules will be:
        /Programs/ROX-Filer/snapshot/share/mime/packages/rox.xml

The manual pages will be:
        /Programs/ROX-Filer/snapshot/man/man1/rox.1
        /Programs/ROX-Filer/snapshot/man/man1/ROX-Filer.1

OK?
[yes/no] >>>    


To which I answer yes, as it all seems resonable, but then I run into
this problem.
Installing manpage...
Installing run actions (existing actions will not be replaced)...
Install MIME-types/application_postscript as /Programs/ROX-Filer/snapshot/share/Choices/MIME-types/application_postscript
Install MIME-types/text as /Programs/ROX-Filer/snapshot/share/Choices/MIME-types/text
Install MIME-types/text_html as /Programs/ROX-Filer/snapshot/share/Choices/MIME-types/text_html
../install.sh: line 217: update-mime-database: command not found
update-mime-database failed
Make sure you have installed the shared MIME database from:
http://www.freedesktop.org/software/shared-mime-info
Aborting...

I have looked through the MakeFiles and sure enough it does a check
and dies if it cannot find the shared-mime-info.

On slackware this was not a problem, all I did was install it, and
apparently Perl and the XML parser module were quite happy, as the
shared-mime-info installed with no problems.

However I did the MakeRecipe with the shared-mime-info tarball and
then get this error:

Compile shared-mime-info
Compile: Locating a recipe for shared-mime-info ...
Compile: Found recipe for shared-mime-info 
GetRecipe: Trying to get /Files/Compile/Recipes/Shared-Mime-INFO/0.14
Compile: Recipe placed in /Files/Compile/Recipes/Shared-Mime-INFO/0.14
Compile: /Files/Compile/Recipes/Shared-Mime-INFO/0.14/Recipe not found

And sure enough there is no recipe.

So I thought I would make my own:

Resolving freedesktop.org... 131.252.208.82
Connecting to freedesktop.org[131.252.208.82]:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 422,311 [application/x-tar]

100%[====================================>] 422,311      179.73K/s             

23:32:02 (179.31 KB/s) - `shared-mime-info-0.15.tar.gz' saved [422311/422311]

MakeRecipe: Shared-Mime-INFO 0.15 build system seems to be based on
Autoconf.

So far so good, however when I Compile it I get the Perl XML
dependency.
checking for perl... /System/Links/Executables/perl
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool
PrepareProgram: configure failed.
Compile: Preparation step failed.

So I decide to install Perl XML, and get this error:

Compile: Environment variable PERL5LIB is not set. Set it to something like /System/Links/Libraries/perl5/site_perl/5.8.0/.

Okay, I tried to set up the environment variable, but it seems that
changing to bash and doing a
PERL5LIB=/System/Links/Libraries/perl5/site_perl/5.8.4/ 
export PERL5LIB 

does not work, although if you echo  $PERL5LIB you get the correct
path.  But calling Compile perl-xml-parser again yields the same
argument about the perl path.

I have dug around in the manual, but it is late and it did not
jump out at me.

At this point I concede defeat.  Any help with setting these variable
would be most appreciated.  I tried putting the above line in the
Recipe in the perl_options line, but it made no difference.

I am interested in installing and trying oroboRox after jonaton's
suggestion, but slowly I am sure I will get there.

Thanks for any help with this puzzle.

Rohan


More information about the Gobolinux-users mailing list