[gobolinux-users] Grub having issues

Rohan NIcholls rohan.nicholls at myrealbox.com
Tue Nov 23 13:14:57 GMT 2004


Sorry for the late reply, I have been away from the computer, and have
had to get things done.  I managed to get lilo working through slackware
on the other partition.

On Thu, 18 Nov 2004 16:17:22 -0200
roko <ro.ko at mcnon.com> wrote:

> Did you follow the instructions in /Depot/Docs/English/Installation
> 
> STEP 5: Bootloader
> 
> Before reboot the system you will need to install a bootloader and
> configure it, if you don't have one installed yet. We suggest GRUB.
> To install it just run
> 
>     grub
>       grub> root (hd*,**)
>       grub> setup --prefix=/System/Kernel/Boot/grub (hd*)
>       grub>quit

Funny that,  I tried this earlier and it gave all sorts of errors, but
now it is working, or at least making settings.

I have editted the menu.lst so we will see on the next reboot.  The
values in menu.lst seem more reasonable.

Thanks for pointing this out, I had read the installation from start to
stop at home, but not here, and had forgotten the grub part as it worked
perfectly with the system at home.

> My /System/Kernel/Boot/grub/menu.lst looks like this (root is
> /dev/hda3)....
> title GoboLinux - Kernel 2.6.6
> kernel (hd0,2)/System/Kernel/Boot/kernel-2.6.6 devfs=mount  
> root=/dev/ide/host0/bus0/target0/lun0/part3 vga=0
> .....

I guess what was confusing me was that menu.lst was already there, and I
had made changes but they were not reflected in start menu, but I think
that was because grub was looking on the wrong partition (the menu.lst
was saying everything was sitting on (hd2,*), because for some reason
that I don't understand the harddrive maps on other linux distros to
/dev/hdc (go figure).

Thanks for the help, everything should be working now.

Rohan


More information about the gobolinux-users mailing list