[gobolinux-users] Alsa muted by default

David Smith dsmith at algonet.se
Fri Aug 5 16:22:31 GMT 2005


Jonas Karlsson wrote:
> By every boot my soundcard becomes muted and doing some searchs on the 
> net  I found out that this is the correct behaviour for alsa, according 
> to the  alsa developers. I believe that this is a source of much 
> unnecesary grief  and debbuging. I know I compiled my kernel three 
> times, with different  soundcard settings (and drivers), because I 
> couldnt get any sound with  alsa before I got the idea to try the 
> alsa-mixer (and found out that all  channels were muted).
> 
> To the point; I found this code while I was doing some searches for  
> getting sound to work with multiple programs (I'm not useing KDE, so I  
> dont use aRTs either):
> 
> /usr/bin/amixer set Master 50 unmute >/dev/null 2>&1
> /usr/bin/amixer set PCM 50 unmute >/dev/null 2>&1
> /usr/bin/amixer set CD 50 unmute >/dev/null 2>&1
> 
> Maybe we should include them in some script to save other user some  
> valuable time.
> 

I have theese lines in the bootscripts, in Init:
   Exec "Restoring ALSA settings..."     alsactl restore
and in Done:
   Exec "Storing ALSA settings..."       alsactl store

I can't remember if I put them there myself or if they were there
from the start, though.

(alsactl saves to a file /etc/asound.state. There is a default
asound.state in the alsa-utils package, but not in the recipe.)

-- 
david


More information about the gobolinux-users mailing list