[gobolinux-users] Re: Gobohide broken on 2.6.12.2?

Jonatan Liljedahl lijon at kymatica.com
Thu Aug 11 18:53:41 GMT 2005


On Thu, 11 Aug 2005 14:15:28 -0300
Hisham Muhammad <hisham.hm at gmail.com> wrote:

> > Another similar issue is the names of binary packages compiled for
> > some specific version of another package. Like the Perl-XML-parser
> > which is compiled for Perl 5.8.6 and won't work with other versions
> > unless you rename the version specific dirs... So the package should
> > be named so you know for what Perl version it's compiled.
> 
> At first this sounds like a good idea, but OTOH Perl is just a "strict
> dependency" for the package (we don't want to start listing dependency
> versions in package version numbers :) ). What we need instead is to
> be able to specify "Perl == 5.8.6" in the dependencies file.

The problem is
/Programs/Perl-XML-Parser/Current/lib/perl5/site_perl/5.8.6/
IMHO, there could (should) be a Perl-XML-Parser binary package available
for each available Perl binary package.
I think it should be named Perl-XML-Parser--2.34--5.8.6--i686.tar.bz2 or
something...

/Jonatan    -=( http://kymatica.com )=-


More information about the gobolinux-users mailing list