[gobolinux-users] NVidia 1.0-7667 HOWTO to GoboLinux012 ?

teike teikecorp at yahoo.com.br
Thu Aug 18 03:51:32 GMT 2005


Uh... I keep forgetting GoboLinux tryes to make users life easyer :).

I compiled Linux kernel (5hours arrg..) with the command:
 Compile --no-install Linux 2.6.11.9
where 2.6.11.9 is my currently running kernel that came with GoboLinux012.
Compile used the file /System/Kernel/Status/config.gz or the one that came with Linux Recipe that is identical.

vermagic almost match to the running kernel o.O, I expected 
  2.6.11.9-Gobo preempt PENTIUMII gcc-3.4
but came
  2.6.11.9 preempt PENTIUMII gcc-3.4

But that doesnt seem to have been the problem, apparently the 'Recipe' for 'Compile Linux' (a patch at it may be) didn't provide identical symbol versions.
  insmod /Files/Compile/Sources/linux-2.6.11.9/drivers/input/joydev.ko
    insmod: error inserting './drivers/input/joydev.ko': -1 Invalid module format
  dmesg
    ...
    joydev: disagrees about version of symbol struct_module

I think this means I would need to actually install the new 'identical?' just compiled kernel so that modules symbols versions do match.
*
Or is there a way to generate really identical/compatible modules to the running GoboLinux012 shipped kernel? any tips?*



Fabio Mierlo wrote:

>In others word:
>
>zcat /System/Kernel/Status/config.gz
>
>On 8/17/05, Leandro Motta Barros <leandro_motta_barros at yahoo.com.br> wrote:
>  
>
>>zcat /proc/config.gz
>>
>>LMB
>>    
>>
>
>
>
>  
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.wotfun.com/pipermail/gobolinux-users/attachments/20050818/d573fe62/attachment.html


More information about the gobolinux-users mailing list