[gobolinux-users] SATA drives not detected

Lucas Correia Villa Real lucasvr at gobolinux.org
Mon Jun 13 12:54:44 GMT 2005


On Sunday 12 June 2005 11:05, RAJ wrote:
> Dear sir,
>         We had downloaded Gobolinux 012 and tried installing in the machine
> which has two SATA drives , but the drives are not getting detected. The
> /dev folder doesnot have sd* type of devices. I had even tried udevstart
> from command line ,but there is no effect for this command.
>
> I experienced similar problem when tried with GoboLinux 012 beta. But After
> executing the command udevstart from the command line , i found that the
> device files sda/sdb got created. I formatted the system and recompiled the
> kernel to SATA device support built in.
>
> Can anyone suggest me a better way to install Gobo 012 in the same machine.

Yes. I've installed 012 on a SATA machine on the last week. First, make sure 
that you only have SATA, and not PATA+SATA configured on the Bios.

After 012 boots and launches the shell, execute:
$ modprobe sd_mod
$ udevstart

These commands will load the SCSI disk driver and will tell udev to create 
the /System/Kernel/Devices entries. After doing that, just create your 
partitions and launch Installer.

One detail: after getting installed, the '/'  entry was not created on fstab. 
I had to mount the target partition again into /Mount/GoboLinux (in the 
LiveCD) and manually add the root filesystem into it:

# Root partition.
/System/Kernel/Devices/sda1 / reiserfs defaults 0 0

Save the file, umount the partition and reboot your machine. Voilà!

-- 
Lucas
powered by /dev/dsp


More information about the gobolinux-users mailing list