[gobolinux-users] LiveCD won't run from USB CD drive

Carlo Calica ccalica at gmail.com
Sun Nov 13 00:41:36 GMT 2005


Try "modprobe usb-storage" and then "mount /dev/scd0 /Mount/CD-ROM". 
Also run dmesg to see if the cd is detected (after the modprobe
usb-storage).

On 11/12/05, Peter Clark <mla-gobo at forrussia.org> wrote:
> On Friday 11 November 2005 19:01, Peter Clark wrote:
> > The cd drive on my laptop recently died, so I got a USB one to replace it.
> > However, Gobo's LiveCD fails part way through, since the old, broken drive
> > is still detected, assumed to be the primary drive, and so when Gobo looks
> > for /Mount/CDRom, it looks at the old drive, rather than the new, and thus
> > isn't able to continue.
> > Popped in Knoppix 3.9 and didn't have any troubles, so at least it's
> > doing something right.
>     Further investigation: I found the following instructions for mounting an
> IDE CD drive on the wiki:
> ] mount / -o remount,rw
> ] cd /dev
> ] mknod hde b 33 0
> ] mount /dev/hde /Mount/CD-ROM
> ] /etc/rc
>
> Under Knoppix and Ubuntu, the USB CD drive is (11, 0) /dev/sr0, so I changed
> the mknod accordingly to:
> ] mknod sr0 b 11 0
> and then tried:
> ] mount /dev/sr0 /Mount/CD-ROM
> but no joy. Also, when I looked at /dev again, the drive had already been
> detected as scd#, where # is 0-4. The major and minor numbers corresponded to
> what I already knew (11, 0), so I tried mounting /dev/scd0. That didn't work.
> On a lark, I tried the others, but that also didn't work. Further
> suggestions?
>     :Peter
> _______________________________________________
> gobolinux-users mailing list
> gobolinux-users at lists.gobolinux.org
> http://lists.gobolinux.org/mailman/listinfo/gobolinux-users
>


--
Carlo J. Calica


More information about the gobolinux-users mailing list