[gobolinux-users] New versions for Scripts, Compile and Manager

Jonas Karlsson jonka750 at student.liu.se
Sat Dec 16 06:49:13 UTC 2006


2006/12/16, André Detsch <detsch at gobolinux.org>:
> New versions for Scripts (2.6.0), Compile (1.8.0) and Manager (1.1.3)
> were just released. The main highlight is the introduction of support
> for recipes and packages revisions. Our recipe store is going to be
> updated really soon to use this new scheme, so, go ahead and update
> those tools at your system.

How about the new OptionParser? Isn't that a highlight as well?
Short on the new OptionParser:
* It's ok to stack short options, so 'Compile -VbW Foo' is the same as
'Compile -V -b -W Foo'
* Long options can use equal sign: 'InstallPackage --same=remove Foo'
is the same as 'InstallPackage --same remove Foo'
* Options can come after arguments: 'SymlinkProgram Foo --force'

>
> Note to whom is still using Glibc 2.3.2: This package for Scripts is
> the last one being linked against Glibc 2.3.2. If your system is based
> on GoboLinux 012 (or older) and you haven't updated your Glibc yet,
> please do it: just install this latest version of Scripts
> ('InstallPackage Scripts') and run 'InstallPackage Glibc' afterwards.
>
I too get strange segfaults since I updated my glibc. I can't run
Window Maker. I'll try to recompile/install it's dependencies linked
with the new version of glibc and see if that helps.

-- 
/Jonas


More information about the gobolinux-users mailing list