[gobolinux-users] Having trouble with software upgrades/installations

Travis Evans travisgevans at cox.net
Fri Dec 22 17:22:02 UTC 2006


Hi, I've been using SUSE Linux for a few years now (originally version 
9.1, then later 9.3, and currently 10.1), and I am now thinking about 
experimenting with other Linux distributions.  I discovered GoboLInux 
and read about it, and the new directory structure organization sounds 
really neat, and I'd really like to try it.  I encountered quite a few 
kinks in the LiveCD/Installation process for GoboLinux 013 initially, 
but I figured those out and installed the system to my extra hard 
drive.

The first thing to try with the new system was to upgrade and install 
the software I would need for the things I do.  That's the problem.  I 
can't figure out how to get the software installation tools working 
right.  This is *not* going smoothly at all, I hate to say.  It's a long 
story, but here it is:

I first tried Manager, since there was an icon for it placed 
conspicuously on the KDE desktop.  As a test, I selected K3B and saw 
that there was an upgrade to version 0.12.17.  I clicked a recipe icon 
for it, right-clicked it and chose "Compile Recipe" and then clicked 
the option to start running the task.  I got permission errors:

------------------------------------------------------------------------
*** Download-1 tab ***
Compile -B K3B 0.12.17
mkdir: cannot create directory `/Files/Compile/LocalRecipes': Permission 
denied
mkdir: cannot create directory `/Files/Compile/Recipes': Permission 
denied
Compile: Locating a recipe for K3B 0.12.17... 
Compile: Found recipe for K3B 0.12.17 
GetRecipe: Trying to get 
http://gobolinux.org/recipe-store/K3B--0.12.17--recipe.tar.bz2 
GetRecipe: Downloading recipe from 
http://gobolinux.org/recipe-store/K3B--0.12.17--recipe.tar.bz2 
Compile: Recipe placed in /Files/Compile/Recipes/K3B/0.12.17 
--12:28:19--  
http://umn.dl.sourceforge.net/sourceforge/k3b/k3b-0.12.17.tar.bz2
           => `k3b-0.12.17.tar.bz2'
Resolving umn.dl.sourceforge.net... 128.101.240.209
Connecting to umn.dl.sourceforge.net|128.101.240.209|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 4,008,650 (3.8M) [application/x-bzip2]

    0K .......... .......... .......... .......... ..........  1%  
272.50 KB/s
   50K .......... .......... .......... .......... ..........  2%  
344.83 KB/s
[...snip...]
 3850K .......... .......... .......... .......... .......... 99%    
1.21 MB/s
 3900K .......... ....                                       100%  
508.57 KB/s

12:28:24 (839.67 KB/s) - `k3b-0.12.17.tar.bz2' saved [4008650/4008650]

Done

*** Compilation-1 tab ***
nice Compile -W K3B 0.12.17
Compile: Locating a recipe for K3B 0.12.17... 
Compile: Found recipe for K3B 0.12.17 
GetRecipe: Trying to get /Files/Compile/Recipes/K3B/0.12.17 
Compile: Recipe placed in /Files/Compile/Recipes/K3B/0.12.17 
Compile: Checking dependencies... 

CheckDependencies: LibSamplerate is not installed. 
CheckDependencies: Unable to fulfill the dependency. 
Compile: Compiling K3B version 0.12.17. 
mkdir: cannot create directory `K3B.0.12.17.Compile.temp': Permission 
denied
Compile: Unpacking file /Files/Compile/Archives/k3b-0.12.17.tar.bz2... 
tar: K3B.0.12.17.Compile.temp: Cannot chdir: No such file or directory
tar: Error is not recoverable: exiting now
aunpack: tar ...: non-zero return-code

bzip2: I/O or other error, bailing out.  Possible reason follows.
bzip2: Broken pipe
	Input file = (stdin), output file = (stdout)
Compile: Could not unpack ''. 
Done
------------------------------------------------------------------------

My first reaction was to pull up a terminal and do a "sudo Manager", but 
that didn't work, either.  I got a Python traceback, and it wouldn't 
start:

------------------------------------------------------------------------
Traceback (most recent call last):
  File "/System/Links/Executables/Manager", line 14, in ?
    from ManagerUI         import *
  File "/System/Links/Libraries/python2.3/site-packages/ManagerUI.py", 
line 11, in ?
    from qt import *
ImportError: libpng.so.0: cannot open shared object file: No such file 
or directory
------------------------------------------------------------------------

So I launched the Manager desktop icon again, and this time after adding 
the Compile Recipe commands for K3B to the command queue, I 
right-clicked them and choose Edit and tried changing them from:

Compile -B K3B 0.12.17
nice Compile -W K3B 0.12.17

to

sudo Compile -B K3B 0.12.17
sudo nice Compile -W K3B 0.12.17

But now, clicking the run button did absolutely nothing, and the console 
listed yet another traceback:

------------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/local/bin/Manager", line 1098, in playToggled
    self.activateNotRunningModules()
  File "/usr/local/bin/Manager", line 1106, in activateNotRunningModules
    started = self.runNextCommand(self.runningModules[module]["logger"], 
self.runningModules[module])
  File "/usr/local/bin/Manager", line 1146, in runNextCommand
    if self.canThisModuleRunThisCommand(runningModule, cmd, 
blockedPrograms) :
  File "/usr/local/bin/Manager", line 1112, in 
canThisModuleRunThisCommand
    p = self.programsAtQueue[cmd]
KeyError: 'sudo Compile -B K3B 0.12.17'
------------------------------------------------------------------------

So then I tried upgrading the package Scripts (again, as a test to try 
to get this working), but the right pane in the Manager window was 
stuck on "Getting information..." and the console displayed yet 
*another* exception:

------------------------------------------------------------------------
/Files/Descriptions/scripts: Permission denied
has wget --timeout=5 --quiet 
http://gobo.calica.com/descriptions/scripts -O /Files/Descriptions/scripts 
&& touch /Files/Descriptions/scripts
Unhandled exception in thread started by <function updateStuff at 
0xb7baa7d4>
Traceback (most recent call last):
  File "/usr/local/bin/Manager", line 845, in updateStuff
    s += method(p,v,t)
  File "/usr/local/bin/Manager", line 760, in updateDescription
    description = DescribeProgram(p, v, mode = 'html', noweb = 
self.configWindow.noWeb.isChecked())
  
File "/System/Links/Libraries/python2.3/site-packages/DescribeProgram.py", 
line 163, in DescribeProgram
    rawDescription = open(localpath+'/'+name).read().strip()
IOError: [Errno 2] No such file or 
directory: '/Files/Descriptions/scripts'
------------------------------------------------------------------------

I tried upgrading Python next, and that time it apparently worked.

Then I tried using Manager to upgrade Manager itself, but it wasn't 
clear to me whether it was successful or not:

------------------------------------------------------------------------
--12:34:55 (433.03 KB/s) - 
`/System/Variable/tmp/Manager--1.1.3--i686.tar.bz2' saved 
[167148/167148]

InstallPackage: Moving package 
to /Depot/Packages/Manager--1.1.3--i686.tar.bz2. 
InstallPackage: Skipping instalation 
of /Depot/Packages/Manager--1.1.3--i686.tar.bz2. 
Done

*** Other-1 ***
InstallPackage --no-dependencies /Depot/Packages/Python--2.5--i686.tar.bz2
InstallPackage: Installing Python, version 2.5. 
InstallPackage: Uncompressing to /Programs... 
InstallPackage: Package Signature Verified 
UpdateSettings: No settings exist 
SymlinkProgram: Symlinking Python 2.5. 
SymlinkProgram: Symlinking global settings... 
SymlinkProgram: Symlinking tasks... 
SymlinkProgram: Storing variable files... 
SymlinkProgram: Symlinking libraries... 
SymlinkProgram: Processed 3 files. 
SymlinkProgram: Updating library database (ldconfig)... 
SymlinkProgram: Symlinking headers... 
SymlinkProgram: Processed 1 file. 
SymlinkProgram: Symlinking info... 
SymlinkProgram: Updating info dir... 
SymlinkProgram: Symlinking manuals... 
SymlinkProgram: Processed 1 file. 
SymlinkProgram: Symlinking executables... 
SymlinkProgram: Processed 7 files. 
SymlinkProgram: Symlinking wrappers... 
SymlinkProgram: Symlinking shared... 
SymlinkProgram: Removing unused directories... 
SymlinkProgram: Waiting for background tasks... 
SymlinkProgram: Done. 
Done

InstallPackage --no-dependencies /Depot/Packages/Manager--1.1.3--i686.tar.bz2
InstallPackage: Installing Manager, version 1.1.3. 
InstallPackage: Uncompressing to /Programs... 
python: error while loading shared libraries: libpython2.5.so.1.0: 
cannot open shared object file: No such file or directory
grep: write error: Broken pipe
InstallPackage: Invalid signature. Package has been modified 
InstallPackage: Suspect package in /Programs/Manager/1.1.3 
Done
------------------------------------------------------------------------

Apparently not, because I was unable to start Manager anymore after 
that:

------------------------------------------------------------------------
/System/Links/Libraries/python2.3/site-packages/ManagerUI.py:11: 
RuntimeWarning: Python C API version mismatch for module qt: This 
Python has API version 1013, module qt has version 1012.
  from qt import *
/System/Links/Libraries/python2.3/site-packages/ManagerUI.py:11: 
RuntimeWarning: Python C API version mismatch for module sip: This 
Python has API version 1013, module sip has version 1012.
  from qt import *
zsh: segmentation fault  Manager
------------------------------------------------------------------------

I went into the /Programs directory and changed the "Current" symlinks 
for the packages I had just upgraded to point to the older versions, 
but that didn't clear the problem.  I had no idea where to begin 
solving this, so I rebooted back into my SUSE system, wiped the 
GoboLinux partition, and restored a backup I had made of the partition 
right after installing GoboLinux but before doing anything else, so 
that Manager would work again and I could have a second chance to 
(hopefully) not hose the GoboLinux system again.

I took the commands shown in the command queue of Manager and 
tried running them in a console.  I got the same permission issues 
with "nice Compile -W K3B 0.12.17", but running "sudo nice Compile -W 
K3B 0.12.17" appeared to work from a terminal, unlike in Manager, where 
I just got an unhandled Python exception error.  It began compiling 
(configure succeeded, and make began) but failed after a while with 
some errors about not being able to find libpng.so.0, even though it 
was installed on my system and appeared to exist in the right places 
(/System/Links/Libraries, /usr/lib, etc.).  I have no idea what would 
cause that.

(By the way, during the K3B compiling process, I got an enormous slew of 
messages at various points like "libtool: link: warning: <path to some 
library> seems to be moved".  Is that normal?  The files it was warning 
about were all symlinks.)

Meanwhile, Manager was still giving me the same problems I mentioned 
above.  At some point, it gave me another traceback different from the 
above ones, but I couldn't remember what I did to cause it, and I didn't 
save the traceback of it.  At this point I gave up on Manager 
completely and tried using the command line tools InstallPackage and 
Freshen (after I figured out that Freshen wasn't included with the 
distribution and I had to install it first, which the GoboLinux web 
pages I found related to it didn't make clear to me).

InstallPackage almost seemed to work, but often when it prompted me 
about installing dependencies partway through the installation, the 
script would print the same prompt three or four times in a row and 
then consume 100% CPU time and do nothing at all no matter what input I 
entered, forcing me to kill the process and try again, leaving me 
wondering if the system is now left in an unstable state due to the 
possibly incomplete installation.  The same thing happened once when it 
asked me about merging configuration for a GTK+ upgrade (which was a 
dependency of something else I updated).  I didn't really understand 
the question.  In fact, it wasn't a question at all, just some prompt 
saying "mod 1: <some files>", leaving me scratching my head.  The only 
clue to me was that the files displayed were in the GTK+ Settings 
directories.  I choose Merge, but again, the script had hung and would 
not respond to any keyboard input.  I forgot what the command was in 
top that looked hung, but it was always a command that looked like the 
one for invoking the prompt and getting the input (the command in top 
had the question and options in the command line).  This process was 
using all available CPU time but was apparently doing nothing useful, 
and did not respond to any of my keyboard input except for Ctrl+C, 
which cancelled the whole thing.

After I had upgraded the KDE packages from 3.5.3 to 3.5.5, I was able to 
log back into KDE, but now there was no font anti-aliasing, all the 
window widgets looked wrong, and most of the styles in KDE Control 
Center > Appearance and Themes > Style were missing... but I guess 
that's a whole different problem.

I'm starting to wonder if I'm completely missing something.  I was not 
able to find anything related to my problems (particularly those with 
Manager and all the tracebacks I was getting right and left) by 
searching Google and the GoboLinux mailing lists.  I can't seem to 
figure out GoboLinux.  

Any ideas?

-- 
Travis Evans


More information about the gobolinux-users mailing list