[gobolinux-users] KDM problem solved; a couple of other issues, maybe...

Travis Evans travisgevans at cox.net
Mon Dec 25 11:26:03 UTC 2006


I was out of ideas, so I used the "divide-and-conquer" approach as a 
last resort.  KDM worked after "SymlinkProgram KDE-Base 3.5.3" but not 
after "SymlinkProgram KDE-Base 3.5.5".  So what was different about 
KDE-Base 3.5.5 that was causing KDM not to work?  I backed up the 
KDE-Base directories and started with a copy 
of /Programs/KDE-Base/3.5.5 and SymlinkProgram'ed it.  Of course, KDM 
didn't work.  Then I copied over directories 
from /Programs/KDE-Base/3.5.3 to the copy of 3.5.5 one at a time, trying 
KDM after every copy.  KDM worked as soon as I copied 3.5.3's Shared 
directory.

So I started back with the original copy of KDE-Base 3.5.5 and copied 
directories over from KDE-Base/3.5.3/Shared one at a time until KDM 
started working again, and so forth.

I eventually narrowed the problem down to a single file: 
KDE-Base/3.5.5/Shared/config/kdm/kdmrc.  Then after some messing 
around, I was able to narrow it down to a single line within that file:

ServerCmd=/Programs/Xorg/6.8.2/bin/X -br

What the...?!  There is no Xorg 6.8.2 installed, and certainly 
no /Programs/Xorg/6.8.2.  Where did that come from?  It should 
be /Programs/Xorg/7.1/..., or better yet 
just /Programs/Xorg/Current/...

And there are several other commented-out lines with "default" values 
pointing to Xorg 6.8.2 as well... go figure.  So, once again starting 
with the original copy of KDE-Base 3.5.5, just correcting that one 
(non-commented) line in that one file made KDM work again.

Now, if KDM had actually printed an error message like "kdmrc: line 
<whatever>: Could not start X server: /Programs/Xorg/6.8.2: No such 
file or directory" or something similar like any properly-designed 
software would, instead of leaving the log file absolutely 
empty, I would have been saved who knows how many hours trying 
to track down this problem.

Now that I could log back into KDE, there were no issues with the 
antialiasing, widget styles, etc., (at least in Qt apps) like the first 
time.  Everything pretty much worked.  I found that Manager still 
wouldn't run, though; it crashed after printing some messages about 
a "Python API mismatch" in the Qt module, probably caused my previous 
upgrade of Python.  I discovered that a precompiled upgrade of PyQt was 
available, and upgrading that fixed the problem, and now Manager once 
again starts up.  I wonder if someone forgot to set the dependencies 
for these packages appropriately, or if the InstallPackage script just 
never got the chance to prompt me since it crashed during the Python 
upgrade.

I discovered now, though, that GIMP is really broken... there are no 
fonts at all; ALL characters in the UI display as rectangles.  It gives 
a lot of Pango errors in the console.  None of my Google searches seem 
to come up with anything that properly relates to this specific 
situation, and I haven't spent much time on that, but I haven't thought 
of where to start looking for the problem yet, so I wonder if anyone 
has any ideas while I take a break from this for a while.  I think it 
worked correctly directly after the original installation--it was 
probably caused at least indirectly by all the upgrades I had to do due 
to dependencies.

It looks like other GTK+ apps work fine (at least, the few I could find 
on the system), though, except that the fonts aren't anti-aliased.  
I've never really used GNOME (which isn't installed on my GoboLinux 
installation, anyway), so I don't have much of a clue yet on 
configuring GTK+ apps' appearances without something like the 
qt-gtk-engine, which I don't really want to use since it caused a lot 
of GTK+ UI-related problems on my SUSE system until I uninstalled it.  I 
did a quick copy of the .gtk* files from my home directory on the SUSE 
system, but that didn't make a difference.  I haven't really looked 
into the format of those config files yet.  I wonder if I need to 
install any GTK+ themes or something to be able to select from 
different styles.

Firefox's UI is still anti-aliased, though, except for the web pages 
themselves, but I'm pretty sure that's because I haven't yet set up the 
default web page fonts to non-bitmapped ones.

-- 
Travis Evans


More information about the gobolinux-users mailing list