[gobolinux-users] Weird build problems

Travis Evans travisgevans at cox.net
Fri Dec 29 19:06:34 UTC 2006


Has anyone at all managed to compile kdeartwork?  I used NewVersion to 
update the available recipe for 3.5.3 to 3.5.5 and tried to build it 
with Compile.  The configure script failed telling me I didn't have 
libXext, even though I installed it.  So when I checked config.log to 
investigate, I saw all kinds of stuff like this:

configure:28628: checking for libXext
configure:28663: gcc -o 
conftest -std=iso9899:1990 -W -Wall -Wchar-subscripts -W
shadow -Wpointer-arith -Wmissing-prototypes -Wwrite-strings -D_XOPEN_SOURCE=500
-D_BSD_SOURCE -DNDEBUG -O2  -O2 -march=i686 -fomit-frame-pointer -pipe -Wformat-
security -Wmissing-format-attribute   -L/usr/lib        libc.so.6 
=> /System/Lin
ks/Libraries/libc.so.6 (0xb7e57000)  conftest.c -lXext -lX11  >&5
gcc: libc.so.6: No such file or directory
gcc: =>: No such file or directory
gcc: (0xb7e57000): No such file or directory
configure:28669: $? = 1
configure: failed program was:
| /* confdefs.h.  */

I'm not really a developer, but that doesn't look like a valid gcc 
command line to me.  What is all the "libc.so.6 => /System/Lin
ks/Libraries/libc.so.6 (0xb7e57000)" junk and where is it coming from?  
GCC thinks "=>" and "(0xb7e57000)" are files--no wonder it doesn't 
work.  I've never come across a problem like this.  Any ideas?

I get the same issue if I just try building it "by hand" with 
CompileProgram.

Google was no help at all.  I wonder if this is a GoboLinux-specific 
issue.

Another problem I'm having when compiling programs in general is that 
make keeps failing because they keep looking in directories of older 
versions of libraries that I removed because they've been upgraded.  
For instance, I originally had GTK 2.8.19 installed, then I upgraded it 
to 2.10.6, SymlinkProgram'ed the new version, then RemoveProgram'ed the 
old version to save disk space, yet make will often fail because 
something keeps looking in /Programs/GTK+/2.8.19, which doesn't exist 
anymore.

I originally tried just making a symlink called 2.8.19 to the new 
version, but then I got another error with the same problem on another 
library, then another, then another... this is getting old very fast.  
What is the likely cause of this?  It's like some system configuration 
is caching the old directories, and the cache needs to be updated.  I 
remember one error like this coming from libtool.  I don't remember if 
any other utilities have the same problem.  How to I get everything 
updated properly?

Finally, are there any more places to find precompiled binaries?  Having 
to compile every single thing I'm planning on using is feeling to me 
like a futile uphill struggle, especially with roughly 50% of all the 
programs I try to compile failing with weird errors that Google doesn't 
help me with, when in the past I was almost always able to find the 
solution by searching on Google.

-- 
Travis Evans


More information about the gobolinux-users mailing list