[gobolinux-users] Perl module problems

Hisham Muhammad hisham.hm at gmail.com
Thu Nov 9 00:39:21 UTC 2006


On 11/8/06, Paul Dann <giddie at christian.net> wrote:
> Hi Hisham, thanks for taking the time to respond to this,
>
>   I didn't know about the cpan interface until Jonas mentioned it, so
> I'm trying it out now.  My main problem is that BackupPC (which is perl
> based) reports not being able to find Compress::Zlib.  Looking into it,
> I assumed it was a problem with the perllocal.pod symlinking, but fixing
> that doesn't seem to have helped.  Cpan feel like another horrible
> package manager, but it seems to be doing a better job of dependency
> checking on the perl modules, which may well be the problem.  If
> dependencies are indeed the problem, can you think of any better way for
> Compile to check them?

A few days ago I compiled a program using Compress::Zlib (CheckGmail)
but ended up forgetting to submit the recipes (shame on me). I just
looked at the other Perl recipes you sent and they look fine, though I
used an older version of Compress::Zlib (1.42) -- maybe there's a
version incompatibility somewhere?

I'm submitting my recipes to the -recipes list now. It might be worth
trying out the older Compress::Zlib and see if it helps.

-- Hisham


More information about the gobolinux-users mailing list