[gobolinux-users] OpenSSH SOCKS difficulty

Andy Feldman nereusren at gmail.com
Fri Nov 17 07:11:27 UTC 2006


I do something almost exactly the same, and it worked fine without
much extra wrangling. I am using OpenSSH 4.3p2 and OpenSSL 0.9.8a on
Gobo 012.

One difference is that I use a password to log in with PuTTY rather
than asymmetric keys... but if you can get a command line when you log
in with PuTTY, I can't see how that would affect the port forwarding.

I can post my PuTTY and Firefox settings tomorrow if you want. (My
sshd seems to be stock, with no extra command-line or sshd_config
options). I followed a simple tutorial that was very similar to this
one: http://thinkhole.org/wp/2006/05/10/howto-secure-firefox-and-im-with-putty/.
Perhaps something in there will fix it for you.

-Andy

On 11/16/06, Paul Dann <giddie at christian.net> wrote:
> Hi there,
>
>   Maybe I'm just being incredibly thick, because I can't find a single
> other instance of this problem on Google:  I Compiled OpenSSH 4.5p1 with
> OpenSSL 0.9.8b and it's working fine.  I'm using asymmetric keypairs (ie
> public/private key).  I'm connecting with PuTTY 0.58 on a Windows XP
> machine, and there's no problem connecting.  However, if I try setting
> up a dynamic port forward (-D 8080) and setting Firefox proxy to
> localhost:8080, it comes up with blank pages.  It does *not* say that
> the proxy can't be found, *or* that the page can't be found, it just
> receives a blank page, containing no HTML at all.  I've tried a couple
> of other versions of OpenSSH, and also tried connecting from different
> computers.  Do I maybe have a library missing, or am I being silly?
> Everything I've read indicates that it should work fine out of the box...
>
> Paul
> _______________________________________________
> gobolinux-users mailing list
> gobolinux-users at lists.gobolinux.org
> http://lists.gobolinux.org/mailman/listinfo/gobolinux-users
>


More information about the gobolinux-users mailing list