[gobolinux-users] OpenSSH SOCKS difficulty

Andy Feldman nereusren at gmail.com
Fri Nov 17 17:36:52 UTC 2006


Paul,

Having tested it today, I found that I can get the same "blank page"
results if I have the proxy settings wrong in Firefox. Make sure you
put the proxy in the SOCKS Host section of Firefox's connection
settings rather than HTTP Proxy.

I think I did the same thing at first, although I didn't remember it
when reading your email. It seemed like HTTP proxy would be the
correct setting, but I tested the SOCKS settings with WinPCap to make
sure it was really using the SSH tunnel for everything. If you set
network.proxy.socks_remote_dns to true in about:config, even your DNS
requests will be routed so people eavesdropping on your local
connection won't be able see the domain names you are requesting.

Anyway, make sure the settings look something like this and you should
be all set: http://thinkhole.org/wp/wp-content/images/firefox-connection-settings.gif.

-Andy

On 11/17/06, Andy Feldman <nereusren at gmail.com> wrote:
> [...]
> I can post my PuTTY and Firefox settings tomorrow if you want. (My
> sshd seems to be stock, with no extra command-line or sshd_config
> options). I followed a simple tutorial that was very similar to this
> one: http://thinkhole.org/wp/2006/05/10/howto-secure-firefox-and-im-with-putty/.
> Perhaps something in there will fix it for you.
>
> On 11/16/06, Paul Dann <giddie at christian.net> wrote:
> > Hi there,
> >
> >   Maybe I'm just being incredibly thick, because I can't find a single
> > other instance of this problem on Google:  I Compiled OpenSSH 4.5p1 with
> > OpenSSL 0.9.8b and it's working fine.  I'm using asymmetric keypairs (ie
> > public/private key).  I'm connecting with PuTTY 0.58 on a Windows XP
> > machine, and there's no problem connecting.  However, if I try setting
> > up a dynamic port forward (-D 8080) and setting Firefox proxy to
> > localhost:8080, it comes up with blank pages.  It does *not* say that
> > the proxy can't be found, *or* that the page can't be found, it just
> > receives a blank page, containing no HTML at all.  I've tried a couple
> > of other versions of OpenSSH, and also tried connecting from different
> > computers.  Do I maybe have a library missing, or am I being silly?
> > Everything I've read indicates that it should work fine out of the box...
> >
> > Paul


More information about the gobolinux-users mailing list