[gobolinux-users] acpi and sound card problems

valerio arnaboldi valerio.arnaboldi at libero.it
Fri Nov 24 07:14:15 UTC 2006


Thanks Lucas,

now acpi works fine, but I have always problems with my sound card!
How can I know if /dev/dsp exists? aumix works whitout errors...
I think drivers are installed properly, but there's some kind of problem 
with initialization. If I start the system with the liveCd the message 
appears too!

Bye,

Valerio

Lucas C. Villa Real ha scritto:
> On 11/23/06, valerio arnaboldi <valerio.arnaboldi at libero.it> wrote:
>   
>> Hi,
>>     
>
> Hi there,
>
>   
>> I'm a Linux newbie and i have just installed Gobolinux on my laptop.
>> I have troubles with acpi installation and soundcard initialization.
>> In the KDE control center i founded that acpi is not completely
>> installed and I have to rebuild the kernel after having enabled AC
>> Adaptor and Control Method Battery, but I don't know how to do this.
>>     
>
> I guess you already have these modules. You just need to modprobe
> them. The list of available modules for acpi is found at
> /System/Kernel/Modules/`uname -r`/kernel/drivers/acpi.
>
>   
>> I have already tried to compile the kernel with a different
>> distribution, but here I can't find /usr/src/'kernel name' and I don't
>> really know what to do!
>>     
>
> I think you can just do that with the existing drivers. However, if
> you really want to compile it, just type 'Compile Linux' in the
> command line (or 'Compile Linux 2.6.17.11' to specify the version).
>
>   
>> The second problem I've met is sound card initialization: every time I
>> start KDE the system prompt out a message like: "Error while
>> initializing sound driver: device: default can't be opened for playback
>> (No such device)". I have a sis integrated sound card and I've also
>> tried to install oss. When I install oss it sais that the driver already
>> exists and then the sound card works, but when I reboot the system the
>> message pops out again and the card doesn't work!
>>     
>
> Do you have a device named /dev/dsp? I'm pretty sure permissions are
> ok on 013, but you might want to double check that, too. You can run
> 'aumix' on the command line, as super user, just to verify that your
> card's mixer was registered by the loaded drivers.
>
>   



More information about the gobolinux-users mailing list