[gobolinux-users] i586 port

Lucas C. Villa Real lucasvr at gobolinux.org
Fri Sep 8 20:04:22 UTC 2006


On 9/8/06, Vojta Grec <gobo at morha.com> wrote:
> Hi,
> thanks for all the fish;-), probably I'll try the iso way (I assume
> it's lot easier;-)). I'll download it by monday because I'm out for
> the weekend. One simple question: is Compile dependent on any concrete
> version of gcc?

No, you can use any gcc version.

> I assume that there is not very recent version in the
> iso, and I'd like to try gcc 4.x (isn't that bad idea? have no
> experience with 4.x), is it possible to compile a new version of gcc
> with the old one or is it rather kind of dependency hell etc.? (Pardon
> my possibly lame questions, I'm using linux for +- 2 years, but always
> used binary distro, so I'm not an expert in compiling;-)).

The iso is shipped with gcc 3.4.1. You can compile a new one just by
issuing 'Compile GCC'. I think you'll need to compile BinUtils too,
but you'll discover that by yourself :-)

> (And if anyone has the time, please try to send me more detailed
> instruction, I'm even not-yet-so-gobo).

Given that you'll have a working distro, all you need to do is follow
the guides to the usage of Compile. There's a lot of documentation on
that in the Wiki, at gobolinux.org/kb.

Cheers,

-- 
Lucas
powered by /dev/dsp


More information about the gobolinux-users mailing list