[gobolinux-users] udev errors

Hi There goboster at yahoo.com
Tue Jun 12 21:31:03 UTC 2007


>On Wed, 06 Jun 2007 21:10:23 +0200, Hi There
><goboster at yahoo.com> 
>wrote:
>
>>> On 6/6/07, Hi There <goboster at yahoo.com> wrote:

>>
>>>> BTW, the -S option seems to get ignored by
>> -=snip=-
>>>> Executed SymlinkProgram to get the new r4 package
>>>> linked in properly.
>>
>>> What version of Scripts are you running there?
That
>>> bug should be
>>> fixed in the last version of Scripts, which is
also
>>> being hold before
>>> someone tests it (could you please do that, too?)
:
>>>
>>>
http://lucasvr.gobolinux.org/etc/Scripts--2.6.5--i686.tar.bz2
>>
>> I had 2.6.4-r1 installed. Just installed new
Scripts,
>> symlinked w/ overwrite after the install.
>>
>> InstallPackage still ignores -S, fails to symlink
>> after detecting an invalid signature.
>>
>Can't reproduce. See below (TPTest is a small
package,
>which I corrupted with a file, "foo", inside the bin
directory.

>]InstallPackage --version
>InstallPackage 2.6.5

>Released under the GNU GPL.
>]VerifyProgram TPTest--3.1.7--i686.tar.bz2
>VerifyProgram: Uncompressing package...
>VerifyProgram: Verifying signature...
>VerifyProgram: Signature OK
>VerifyProgram: Verifying FileHash...
>VerifyProgram: FileHash check failed: bin/foo not
found in hashfile
>VerifyProgram: Removed package >from
/System/Variable/tmp
>]InstallPackage -S TPTest--3.1.7--i686.tar.bz2
>InstallPackage: An installation of this same version
already exists.
>InstallPackage: Remove existing?
>[R]emove/[k]eep/[c]ancel
r

>InstallPackage: Installing TPTest, version 3.1.7.
>InstallPackage: Uncompressing to /Programs...
>InstallPackage: Skipping package's signature
verification.
>UpdateSettings: No settings exist
>SymlinkProgram: Symlinking TPTest 3.1.7.
>[snip]
>SymlinkProgram: Removing unused directories...
>SymlinkProgram: Done.
>I got the same result if I tried Scripts 2.6.3 and
2.6.4
>(those were the versions I had available on my
machine), so
>I can't really find why you have a problem with the
'-S'
>option.

weird, I had the same problem with 2.6.4. well what
sort of thing could be causing this problem? as I
noted in a previous post, HAL recipe fails on a python
XML package dependency that *is* installed, maybe some
python library or search path is borked?

again, just to check my versions:
]InstallPackage --version
InstallPackage 2.6.5

Released under the GNU GPL.
root at homecomputer /]python --version
Python 2.5


>> ]InstallPackage -S udev
>> -=snip=-
>> InstallPackage: Invalid signature.  Package has
been
>> modified
>I can verify that the signature was invalid. I have
uploaded
>a new package, with valid signature.

Thanks!


in any case, udev-110 is still broken for me. I
downgraded to 105 in the meantime, that seems to be
working better. is there any more info I can give you
to help get it fixed?




       
____________________________________________________________________________________
Sick sense of humor? Visit Yahoo! TV's 
Comedy with an Edge to see what's on, when. 
http://tv.yahoo.com/collections/222


More information about the gobolinux-users mailing list