[gobolinux-users] /dev/dsp disappeared after upgrade

Hi There goboster at yahoo.com
Thu Jun 21 07:46:57 UTC 2007


Got sound working even a little better now. In case
anyone was having similar 
problems, I added a module -- something like OSS Mixer
-- to the kernel, then I 
was getting an error stating /dev/dsp was already in
use at startup. Some old 
Ubuntu forums state this is due to artsd hogging
/dev/dsp at startup. So I 
killed artsd, got sound back in all my apps but KDE.
Disabled "enable sound 
system" in the control panel, no errors at startup
(and no sound from KDE).

At least Amarok works now. 


I <goboster <at> yahoo.com> wrote:

> 
> Lucas said:
> >On 6/5/07, Hi There <goboster at yahoo.com> wrote:
> >> One of many problems I've encountered after
> upgrading
> >> to newer packages (KDE, kernel, xorg, udev) is
that
> >> sound has stopped working. I think it happened at
> the
> >> KDE upgrade stage. There is no longer a /dev/dsp
> >> present. KDE pops up a window at startup:
> >>
> >> Error while initializing the sound driver:
> >> device /dev/dsp can't be opened (No such file or
> >> directory)
> >> The sound server will continue, using the null
> output
> >> device.
> 
> >Please take a look at the other thread. I just
> >replied about this problem there.
> 
> >> BTW, can't Compile ALSA-Driver 1.0.13-r2, it
gives
> >> kernel header file errors, looks like it's not
> >> compatible with kernel 2.6.21.1.
> 
> >Since you're running an updated kernel I don't
think
> >there's a good
> >reason to compile a stand-alone alsa driver package
> >(unless there were
> >important enhancements to your sound card's driver
> >since then).
> 
> Just mentioned that because some people in gentoo
> forums suggested using the older, stable,
stand-alone
> alsa drivers when having trouble. Doesn't matter
much
> because... 
> 
> I'm making some progress on the problem. The
> snd_mixer_oss and snd_pcm_oss modules weren't being
> loaded at startup, and those are the ones
responsible
> for the /dev/dsp entry. I added those two modules to
> the 
> UserDefinedModules entry in BootOptions. Now I have
a
> /dev/dsp again, and an application (mplayer) plays
> sound again.
> 
> This thread at the gentoo forums helped get me this
> far http://forums.gentoo.org/viewtopic-t-279086.html
> 
> Unfortunately, I can't get sound out of KDE itself.
No
> startup sounds, and the "Test" button in the Control
> Center's Sound System panel does nothing. KMix does
> change the volume level of mplayer. Under Sound
System
> -> Hardware -> Select the audio device, ALSA is not
> listed, I'm pretty sure it is in most KDE
> environments.
> 
> Amarok also fails to output sound giving the error
> "xine was unable to initialize any audio drivers" at
> startup. I tried all of the suggestions in this
Ubuntu
> thread
> 
http://ubuntuforums.org/showthread.php?s=be011084f8b6459760b7db081b758a44&t=102064&page=3
> none worked.
> 
> So where are these modules supposed to be loaded, if
> not from UserDefinedModules? I didn't have oss
entries
> in there before, and sound worked fine. They're not
in
> /etc/modprobe.conf either (blacklist or alias). Am I
> supposed to have some sound entries in there? Is
udev
> supposed to be taking care of this stuff?
> 
> I added the alias entries suggested here
>
http://bugtrack.alsa-project.org/main/index.php/Matrix:Module-hda-intel
> to /etc/modprobe.conf, and used their suggested
> .asoundrc file in my home directory just in case
that
> was the missing ingredient. KDE and Amarok still
> refuse to work.
> 
> >-- 
> >Lucas
> >powered by /dev/dsp
> 
> --
> Mike
> barely powered by /dev/dsp
> 
>        
> 
____________________________________________________________________________________
> Looking for a deal? Find great prices on flights and
hotels with Yahoo! 
FareChase.
> http://farechase.yahoo.com/
> 





       
____________________________________________________________________________________
Take the Internet to Go: Yahoo!Go puts the Internet in your pocket: mail, news, photos & more. 
http://mobile.yahoo.com/go?refer=1GNXIC


More information about the gobolinux-users mailing list