[gobolinux-users] Udev errors

Hisham Muhammad hisham.hm at gmail.com
Tue Sep 4 00:36:19 UTC 2007


Hi,

I'm fighting with Udev as well. I'm working on a recipe for version
115. I'll post it here before committing. Could you test it?

Thanks in advance,

-- Hisham

On 9/3/07, Anshuman Aggarwal <anshuman at brillgene.com> wrote:
> Here are the errors that I get at startup:
>
> Aug 27 09:39:57 (none) dhcpcd[3167]: timed out waiting for a valid DHCP
> server response
> Aug 27 09:40:40 (none) udevd-event[4125]: delete_path:
> rmdir(/System/Kernel/Devices) failed: Device or resource busy
> Aug 27 09:40:40 (none) udevd-event[4131]: run_program: exec of program
> '/lib/udev/udev_run_hotplugd' failed
> Aug 27 09:40:40 (none) udevd-event[4132]: run_program: exec of program
> '/lib/udev/udev_run_devd' failed
> Aug 27 09:40:40 (none) udevd-event[4126]: delete_path:
> rmdir(/System/Kernel/Devices) failed: Device or resource busy
> Aug 27 09:40:40 (none) udevd-event[4135]: run_program: exec of program
> '/lib/udev/udev_run_hotplugd' failed
> Aug 27 09:40:40 (none) udevd-event[4136]: run_program: exec of program
> '/lib/udev/udev_run_devd' failed
> Aug 27 09:40:40 (none) udevd-event[4140]: run_program: exec of program
> '/lib/udev/udev_run_hotplugd' failed
> Aug 27 09:40:40 (none) udevd-event[4141]: run_program: exec of program
> '/lib/udev/udev_run_devd' failed
>
> Although its not directly impacting anything, something seems to be
> broken with the Udev 110 Recipe (or it could be just my system...though
> I have recompiled everything related)
>
> I did some investigation around udev and here it is:
> looks like there is a default rule in 50-udev.rules which calls this file
> 50-udev.rules:ENV{UDEVD_EVENT}=="1", RUN+="/sbin/udev_run_hotplugd
> $env{SUBSYSTEM}"
>
> Now udev_run_hotplugd is:
> -------------------------------------
> boss@ /Programs/Udev/110]cat /sbin/udev_run_hotplugd
> #!/bin/sh
>
> exec /lib/udev/udev_run_hotplugd $*
> ------------------------------
> but this file /lib/udev/udev_run_hotplugd does not extist and throws the
> errors in the Bootup
>
> Are there other people experiencing the same???
>
>
> Thanks,
> Anshuman
>
>
>
> More data below:
> System: 2.6.22.1 kernel, all packages are pretty recent...no svn packages
>
>
> boss@ /System/Settings/udev/rules.d]l
>
> 26/08 16:04 rwxrwxrwx       56 05-udev-early.rules ->
> /Programs/Udev/Settings/udev/rules.d/05-udev-early.rules
> 26/08 16:04 rwxrwxrwx       50 10-udev.rules ->
> /Programs/Udev/Settings/udev/rules.d/10-udev.rules
> 26/08 16:04 rwxrwxrwx       50  ->
> /Programs/Udev/Settings/udev/rules.d/50-udev.rules
> 26/08 16:04 rwxrwxrwx       53 51-hotplug.rules ->
> /Programs/Udev/Settings/udev/rules.d/51-hotplug.rules
> 26/08 16:04 rwxrwxrwx       54 52-hotplugd.rules ->
> /Programs/Udev/Settings/udev/rules.d/52-hotplugd.rules
> 26/08 16:04 rwxrwxrwx       54 60-cdrom_id.rules ->
> /Programs/Udev/Settings/udev/rules.d/60-cdrom_id.rules
> 26/08 16:04 rwxrwxrwx       62 60-persistent-input.rules ->
> /Programs/Udev/Settings/udev/rules.d/60-persistent-input.rules
> 26/08 16:04 rwxrwxrwx       64 60-persistent-storage.rules ->
> /Programs/Udev/Settings/udev/rules.d/60-persistent-storage.rules
> 26/08 16:04 rwxrwxrwx       66 75-cd-aliases-generator.rules ->
> /Programs/Udev/Settings/udev/rules.d/75-cd-aliases-generator.rules
> 26/08 16:04 rwxrwxrwx       70 75-persistent-net-generator.rules ->
> /Programs/Udev/Settings/udev/rules.d/75-persistent-net-generator.rules
> 27/08 06:39 rw-r--r--      607 70-persistent-cd.rules
> 27/08 06:39 rw-r--r--      454 70-persistent-net.rules
> ============================================================================================================================================
>      1640 in 12 files - reiserfs: 8053548 kB used (86%), 1275184 kB free
> boss@ /System/Settings/udev/rules.d]grep hotplug
>
> boss@ /System/Settings/udev/rules.d]grep hotplug *
> 50-udev.rules:# be backward compatible for a while with the /etc/dev.d
> and /etc/hotplug.d/ systems
> 50-udev.rules:# run /etc/hotplug.d/ stuff only if we came from a hotplug
> event, not for udevstart
> 50-udev.rules:ENV{UDEVD_EVENT}=="1", RUN+="/sbin/udev_run_hotplugd
> $env{SUBSYSTEM}"
> 51-hotplug.rules:ACTION!="add", GOTO="hotplug_not_add_event"
> 51-hotplug.rules:ENV{DRIVER}=="?*", SUBSYSTEM!="input",
> GOTO="hotplug_driver_loaded"
> 51-hotplug.rules:# rules for subsystems which lack proper hotplug support
> 51-hotplug.rules:# From here on follows the hotplug agents which do not
> load modules
> 51-hotplug.rules:LABEL="hotplug_driver_loaded"
> 51-hotplug.rules:LABEL="hotplug_not_add_event"
> 51-hotplug.rules:# Log every event to /dev/hotplug.log (for debugging).
> 52-hotplugd.rules:# do not call hotplug.d and dev.d for "drivers" and
> "module" events
> 52-hotplugd.rules:# compatibility support for the obsolete hotplug.d and
> dev.d directories
> 52-hotplugd.rules:RUN+="udev_run_hotplugd $env{SUBSYSTEM}"
>
> boss@ /System/Settings/udev/rules.d]ll /sbin/udev_run_hotplugd
> lrwxrwxrwx 1 boss root 55 2007-08-26 14:41 /sbin/udev_run_hotplugd ->
> /Programs/Udev/110/Resources/Wrappers/udev_run_hotplugd
>
> _______________________________________________
> gobolinux-users mailing list
> gobolinux-users at lists.gobolinux.org
> http://lists.gobolinux.org/mailman/listinfo/gobolinux-users
>


More information about the gobolinux-users mailing list