[gobolinux-users] KDE upgrade to 3.5.7 failed because Mesa 7.0-r1 FTBFS

Jonas Karlsson jonka750 at student.liu.se
Tue Sep 4 21:35:08 UTC 2007


On Tue, 04 Sep 2007 23:29:31 +0200, rubisher <rubisher at scarlet.be> wrote:

> Jonas Karlsson wrote:
>> On Thu, 30 Aug 2007 14:56:33 +0200, rubisher <rubisher at scarlet.be> wrote:
>>
>>> Jonas Karlsson wrote:
>>>> Mesa lacks Makedepend as a build dependency. You can run 'Compile
>>>> makedepend' in the meantime to install it.
>>> Ok I will continue so ;-)
>>>
>>>> Please file a bug against the Mesa recipe.
>>>>
>>> done: <http://bugs.gobolinux.org/view.php?id=136>
>>>
>> When I was looking at fixing this bug I noticed that Mesa indeed has Makedepend
>> as *BuildDependency*. So the bug seems to be in Freshen or Compile, that the
>> responsible application doesn't look at BuildDependencies as well (when
>> compiling). Compile uses CheckDependencies for this, but I don't know how
>> Freshen does.
>>
> I just noticed the same difference of behaviour when I Compile HAL:
> it ask me if I want to install some build dependencies (namely Intltool, Perl-XML-Parser) what din't do Freshen?
>
Did Freshen ask or not ask you to install these dependencies? Or was it Compile that did (or didn't) ask?

-- 
/Jonas

Using Opera's revolutionary e-mail client: http://www.opera.com/mail/


More information about the gobolinux-users mailing list