[gobolinux-users] freshen 2.2.7 crash

Hisham Muhammad hisham.hm at gmail.com
Wed Sep 19 04:39:27 NZST 2007


On 9/18/07, MJ Ray <mjr at phonecoop.coop> wrote:
> "Hisham Muhammad" <hisham.hm at gmail.com> wrote:
> > Two ways of breaking the cycles:
> >
> > * When installing binary packages, cycles can be broken without too
> > much trouble because the installation order doesn't matter that much
> > as long as all dependencies are satisfied in the end.
>
> Is that still true if one of the packages in the cycle is required by
> Scripts? (ZSH, Python or one of their dependencies, at a guess.)

Right, I neglected to mention the bootstrapping issues. This condition
may not hold for that case, but the second condition below also holds
for binary packages, so in practice it probably covers any cycles in
the Scripts dependency graph.

> > * When compiling packages, cycles can be broken if the older,
> > currently installed version of the package satisfies the dependency.
>
> Seems true.

-- Hisham


More information about the gobolinux-users mailing list