[gobolinux-users] recipe looking for libstdc++ in non-existent dir

Jonas Karlsson jonka750 at student.liu.se
Tue Feb 5 21:30:50 NZDT 2008


2008/2/5, Hi There <goboster at yahoo.com>:
> The enchant recipe is giving me trouble: it looks for libstdc++.la at
> /Programs/GCC/4.1.1/lib/libstdc++.la and dies with error messages from grep,
> sed, and libtool ending with:
>
> libtool: link: `/Programs/GCC/4.1.1/lib/libstdc++.la' is not a valid libtool
> archive.
>
> I have 4.1.2 installed & active. There is no GCC 4.1.1 on my system. I checked
> the /System/Links/Libraries/libstdc++.la link, and it points to
> /Programs/GCC/4.1.2/lib/libstdc++.la, which is correct. I tried SymlinkProgram
> -f and also the LibStdC++ recipe to no avail.
>
> This sort of thing has happened to me before, and I worked around it by creating
> a link from the missing version's library to the current version's, but that is
> quite a hack. I'd like to get to the root of the problem.
> Is it just a bad recipe?
>
No, you just have a reference to the GCC Programs entry in either one
of your .la or .pc files. Try:

find /System/Links/Libraries -name "*.la" -or -name "*.pc" | FixDirReferences

to fix this.

-- 
/Jonas


More information about the gobolinux-users mailing list