[gobolinux-users] problem in Compile of Mplayer

Jonas Karlsson jonka750 at student.liu.se
Sat Feb 9 10:01:25 NZDT 2008


On Fri, 08 Feb 2008 21:58:05 +0100, Viola Zoltán <violazoli at gmail.com> wrote:

> Dear Jonas, this command write me nothing:
>
> pv at Csiszilla ~]grep \/glib-2.0 /System/Links/Libraries/pkgconfig
> pv at Csiszilla ~]
>
> After this trying, I Disable the old GLib software, and Symlink the 2.14.4,
> and try Compile the Mplayer.
> In case, as the Compile write me existing source, I answer the [R]emove and
> reunpack:
>
> Compile: Directory '/Files/Compile/Sources/MPlayer-1.0rc2' already exists.
> Compile: What to do? [R]emove and reunpack/[B]ackup and reunpack/[U]se
> it/[C]ancel.
> R
>
> But, the compile process failed, see as:
>
> ar r libosdep.a timer-lx.o getch2.o mmap_anon.o shmem.o
> ar: creating libosdep.a
> true libosdep.a
> make[1]: Leaving directory `/Files/Compile/Sources/MPlayer-1.0rc2/osdep'
> cc -o mplayer mplayer.o m_property.o mp_fifo.o mp_msg.o mixer.o
> parser-mpcmd.o subopt-helper.o command.o asxparser.o codec-cfg.o cpudetect.o
> edl.o find_sub.o get_path.o m_config.o m_option.o m_struct.o mpcommon.o
> parser-cfg.o playtree.o playtreeparser.o spudec.o sub_cc.o subreader.o
> vobsub.o unrarlib.o libvo/libvo.a libao2/libao2.a input/libinput.a
> vidix/libvidix.a gui/libgui.a libmpcodecs/libmpcodecs.a libaf/libaf.a
> libmpdemux/libmpdemux.a stream/stream.a libswscale/libswscale.a
> libvo/libosd.a libavformat/libavformat.a libavcodec/libavcodec.a
> libavutil/libavutil.a libpostproc/libpostproc.a loader/libloader.a
> mp3lib/libmp3.a liba52/liba52.a libmpeg2/libmpeg2.a libfaad2/libfaad2.a
> tremor/libvorbisidec.a dvdread/libdvdread.a libdvdcss/libdvdcss.a
> libass/libass.a osdep/libosdep.a -ldirectfb -lXext -lX11 -lpthread -lXv
> -lXinerama -lXxf86vm -lXxf86dga -lGL -ldl
> -Wl,-rpath,/Programs/SDL/1.2.11/lib -lSDL -lpthread -ldl -lartsc -lpthread -
> lgmodule-2.0 -ldl -lgthread-2.0 -lrt -lglib-2.0 -lesd -laudiofile -lm
> -lasound -laudiofile -lm -ljack -lfaac -lmp3lame -lgtk-x11-2.0 -lgdk-x11-2.0-
> latk-1.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lpango-1.0 -lcairo -lgobject-2.0-
> lgmodule-2.0 -ldl -lglib-2.0 -lglib-2.0 -L/Programs/Audiofile/0.2.6/lib
> -L/Programs/Audiofile/0.2.6/lib -L/Programs/Esound/0.2.38/lib
> -L/Programs/GLib/2.12.11/lib -L/Programs/KDE-Libs/3.5.8/lib
Ok, this time it's library references. Could you please try 'grep "2.12.11"
/System/Links/Libraries/*.la'?

-- 
/Jonas

Using Opera's revolutionary e-mail client: http://www.opera.com/mail/


More information about the gobolinux-users mailing list