[gobolinux-users] Problem compiling BMPx (libSoup/PkgConfig related)

Thomas Queste tqueste at free.fr
Mon Mar 3 10:50:50 NZDT 2008


BMPx, a music player, has somme dependencies, for example boost and libSoup.
I'm stuck with the second, libSoup. It compiles well but BMPx can't find 
it. It is related to PkgConfig and I don't know what to do.

I have libSoup :
gobo at Gobo ~]ls /Programs/LibSoup
2.3.2/  Current@  Settings/


Here is the error message :
----------------------------------------------------------------
checking for pkg-config... /System/Links/Executables/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for SOUP... configure: error: Package requirements (libsoup-2.2 
 >= 2.2.100) were not met.
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively you may set the SOUP_CFLAGS and SOUP_LIBS environment 
variables
to avoid the need to call pkg-config.  See the pkg-config man page for
more details.
PrepareProgram: configure failed.
Compile: Preparation step failed.
gobo at Gobo ~]echo $PKG_CONFIG_PATH
/System/Links/Libraries/pkgconfig
----------------------------------------------------------------

There is a file in pkgconfig:
/System/Links/Libraries/pkgconfig/libsoup-2.4.pc


Thanks for your help,

Tom

-- 
Thomas
mailto:tqueste at free.fr


More information about the gobolinux-users mailing list