[gobolinux-users] Issues while building Mercurial

Daed Lee daed at thoughtsofcode.com
Fri Apr 3 19:01:49 NZDT 2009


2009/4/2 Michael Homer <michael at gobolinux.org>:
>> Lastly, I was prompted during the Mercurial build to install Python
>> 3.0.1 as a dependency. As far as I can tell Python 3.0 isn't backward
>> compatible with Python 2.x. Should the recipe be changed so that the
>> Dependency file reads "Python < 3.0" (not sure if that's the correct
>> syntax)?
> Yes,  that should be updated. New recipe committed.

Michael, I tried out the new recipe you committed. I get a prompt for
a Python version below 3.0 now, but the Python 3.0.1 dependency still
shows up. Is this a bug?

CheckDependencies: Python is not installed.
CheckDependencies: Compile recipe for Python 2.6.1 or skip this
dependency? [C]Compile/[S]Skip/[CA]Compile All/[SA]Skip All
C

CheckDependencies: Python is not installed.
CheckDependencies: Compile recipe for Python 3.0.1 or skip this
dependency? [C]Compile/[S]Skip/[CA]Compile All/[SA]Skip All
S


More information about the gobolinux-users mailing list