[gobolinux-users] Rootless GoboLinux on Ubuntu: problems when sudoing

Lucas C. Villa Real lucasvr at gobolinux.org
Wed Mar 4 21:33:38 NZDT 2009


On Sat, Feb 28, 2009 at 3:31 PM, mpb <mpb.mail at gmail.com> wrote:
> On Sat, Feb 28, 2009 at 12:30 AM, Lauri Oksanen <lsoksane at gmail.com> wrote:
>> Hi,
>>
>> I tried to do the following
>>
>> sudo -i
>> source StartRootless
>> Compile MTail
>>
>> And got this error (plus some others caused by this)
>>
>> /home/lsoksane/work/linux/gobotc/System/Links/Executables/Compile:
>> line 9: ScriptFunctions: No such file or directory
>>
>> Doing this without sudoing works just fine.
>>
>> Any quick fixes for this? I don't have to be root to Compile, of
>> course, but what I really would like to do is to play with
>> ChrootCompile.
>>
>> - Lauri
>
> I cannot tell exactly what you are trying to do...
>
> Perhaps something like this would help:
>
> sudo -i
> mkdir ~/gobo
> cd ~/gobo
> bash CreateRootlessEnvironment
> <snip>
> Compile Mtail
>
> In other words, if you want to play with Rootless as root, I think it
> might help to CreateRootlessEnvironment as root, too.  ~/gobo is just
> an example; choose whatever directory you want.

True. You need to have the environment prepared in root's home directory, too.

> I never tried Compiling in the same Rootless environment as both root
> and non-root.  I suspect it would cause problems eventually.  (I
> always used Rootless as a non-root user.)

It should work, as long as installation goes into each user's $HOME
directory or no access restrictions are imposed in $goboPrefix.

Lucas


More information about the gobolinux-users mailing list