[gobolinux-users] anyone installed Qt?

Michael Homer michael at gobolinux.org
Thu Jan 21 12:18:52 NZDT 2010


On Thu, Jan 21, 2010 at 3:32 AM, Lucas C. Villa Real
<lucasvr at gobolinux.org> wrote:
> On Wed, Jan 20, 2010 at 10:49 AM, Eric Alan Solo
> <sambarino1337 at gmail.com> wrote:
>> Hi everyone,
>> Last time i tried, by "InstallPackage Qt" it ended up killing my
>> installation (was probably the new glibc it installed as a dependency)
>> so this time i want to ask first if anyone knows how to do it without
>> breaking things? I need atleast version 4 of Qt.
> I would suggest you to use Compile Qt instead, which will compile it
> from the sources and adjusting to the version of libraries that you
> already have installed on your machine.
Lucas is right, but also note that you should always always upgrade
your tools before you do anything else after a new install. The Glibc
package should install correctly with any recent Scripts package, and
compile correctly with any recent Compile package. If it asks you to
install Glibc during the tools upgrade process, you should say no.

These complexities should be ironed out once we have a new release,
which is hopefully soon. There'll be a better base to work from when
we do, both less out-of-date and we can make the first steps simpler.
I'd also like to work some better upgrade help into Freshen which
might be more useful (now it just spews a warning when Glibc comes
up).
-Michael


More information about the gobolinux-users mailing list