[gobolinux-users] My GoboLinux experience thus far

John Askme anotherjohn at hotmail.com
Sun Jan 31 01:21:35 NZDT 2010


Hi all

Warning: lengthy ramble ahead.

First time poster here - please let me know if I'm posting in the wrong place!

Overall Linux experience (~2 years):

Cygwin -> Ubuntu/Wubi -> Ubuntu/native -> Arch -> Ubuntu + Arch + will-try-anything

Before discovering Ubuntu/Wubi, I seriously considered Gobo as my first distro, though I now realise that would have been a big mistake :).

Gobo experience thus far:

Installation went smoothly. Console font/colours were beautiful! Installer didn't offer to use an existing swap partition - a minor quibble. Was a bit disappointed that 'gobo' wasn't offered as the default admin account name - I had to type it myself (the default was 'root').

Didn't like the grub splash screen, because it (apparently) didn't offer to drop to the grub console, which can be useful when I occasionally accidentally reboot instead of shutdown, or need to manually chainload etc. Easily disabled though, so just a minor quibble.

Had a nose around the system and liked it. Was mildly disappointed to see that the links in System/Links/Executables etc don't go through Programs/Pkg/Current, but point directly to a particular version. Assumed there was a good reason for this (not just 'efficiency').

Very nice default manpage viewer, by the way.

I realise now that I was a bit too blase about things - I had no idea how broken stuff could get :). I'll be more careful next time.

First thing I tried to do was install the NVidia driver. Having now seen the oddly-named 'Afterboot' page in the Wiki (which isn't linked from the install page, incidentally), I realise that this was a mistake. Next time I will just do without it (I'd rather play with Xen anyway).

In the screenfuls of stuff that followed 'Compile Nvidia' there were many red Conflict: Programs/blah/blah/blah/something.h lines. I assumed this was to be expected, given that it carried on regardless.

It eventually stopped with a complaint that one of the packages required a more recent version of Compile.

Tried 'InstallPackage Compile' - no joy. Tried 'Compile Compile', which eventually stopped with a complaint that I needed a more recent version of Scripts. Tried 'InstallPackage Scripts' - no joy. Tried 'Compile Scripts', which eventually terminated with a complaint that I needed a more recent version of Compile.

Spotted 'Perl-something-something' in the output described as a prerequisite for updating Scripts. Tried Compile on it and eventually got a dependency on a more recent version of Glibc. Assumed it was OK to just go ahead and install it, given the promise that multiple versions can live side-by-side :)

After more compilation guff, eventually got a red line that I had seen previously when a downloaded package is the same version as an installed package, this time relating to Glibc. All the messages after that point were segfaults, and the system was unable to spawn new processes - a state I had never seen before :). A busybox-like shell with compiled-in versions of essential commands might have been useful at this point ...

By the way, I did all this from my 'normal user' account, created during installation, without ever using 'sudo'. Checking the 'admin' box gave me a whole lot more than just 'sudo' :)

My Gobo partition no longer boots (unsurprisingly!), but instead of just reinstalling over it, I would like to first endeavour to fix it, as a learning exercise.

Thank you for reading! To be continued ...

John




 		 	   		  
_________________________________________________________________
Send us your Hotmail stories and be featured in our newsletter
http://clk.atdmt.com/UKM/go/195013117/direct/01/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.gobolinux.org/pipermail/gobolinux-users/attachments/20100130/8aa14cf0/attachment.htm>


More information about the gobolinux-users mailing list