[gobolinux-users] My GoboLinux experience thus far

Samuel A. Falvo II sam.falvo at gmail.com
Sun Jan 31 06:15:06 NZDT 2010


2010/1/30 John Askme <anotherjohn at hotmail.com>:
> Didn't like the grub splash screen, because it (apparently) didn't offer to
> drop to the grub console, which can be useful when I occasionally
> accidentally reboot instead of shutdown, or need to manually chainload etc.
> Easily disabled though, so just a minor quibble.

You can press the ESC key to drop to a grub prompt.  Likewise with the
graphical Lilo interface as well.

> I realise now that I was a bit too blase about things - I had no idea how
> broken stuff could get :). I'll be more careful next time.

What became broken?

> First thing I tried to do was install the NVidia driver. Having now seen the
> oddly-named 'Afterboot' page in the Wiki (which isn't linked from the
> install page, incidentally), I realise that this was a mistake. Next time I
> will just do without it (I'd rather play with Xen anyway).

I'm running the nVidia driver...works for me.

> In the screenfuls of stuff that followed 'Compile Nvidia' there were many
> red Conflict: Programs/blah/blah/blah/something.h lines. I assumed this was
> to be expected, given that it carried on regardless.

This is annoying; now that Gobo has solved the "multiple versions of
programs" problem, I think it needs to eventually solve the "multiple
versions of header and config files" problem next.  Unfortunately,
this is an even harder problem to solve.

In the mean time, I understand that Compile has a flag you can pass to
it (though I cannot recall what it is at the moment) which forces
conflicts to be resolved.  Resolution options include keeping the
original files, overwriting the files with the newer version, etc.

> segfaults, and the system was unable to spawn new processes - a state I had
> never seen before :). A busybox-like shell with compiled-in versions of
> essential commands might have been useful at this point ...

If you boot your Gobo installation with a rescue disk or CD, you can
type in the following as root user:

SymlinkProgram Glibc <old-version>

If I'm not mistaken, that will be sufficient to get your system back
into working order.  I ran into this problem some years ago (hence why
I don't recall if this is sufficient to restore operation), and
henceforth vowed forever more to *NEVER* upgrade glibc without also
upgrading the entire distribution.

-- 
Samuel A. Falvo II


More information about the gobolinux-users mailing list