[gobolinux-users] My GoboLinux experience thus far

Michael Homer michael at gobolinux.org
Sun Jan 31 11:22:56 NZDT 2010


On Sunday 31 January 2010 01:21:35 John Askme wrote:
> Hi all
> ...
> I realise now that I was a bit too blase about things - I had no idea how
>  broken stuff could get :). I'll be more careful next time.
> 
> First thing I tried to do was install the NVidia driver. Having now seen
>  the oddly-named 'Afterboot' page in the Wiki (which isn't linked from the
>  install page, incidentally), I realise that this was a mistake. Next time
>  I will just do without it (I'd rather play with Xen anyway).
If the first thing you do isn't to upgrade your tools, everything is going to 
come tumbling down in short order, as you saw. Several of the subsequent 
problems come at least in part from not doing that. Scripts first, then 
Compile; if it asks you to upgrade Glibc during that, say no (you can do it 
afterwards if you want, but it's not necessary).

A rough recipe to follow would be:
InstallPackage Scripts
InstallPackage Compile
Compile LibXML2
SymlinkProgram -f Scripts

The package signature format changed between 014 and now to fix a potential 
issue, so Scripts won't validate. You can just run `SymlinkProgram Scripts 
2.10.1` if you want to take it on faith that it's uncompromised. You can also 
install 2.9.1 as an intermediate step, which is able to validate the new form 
but signed with the old, or you can use this hacked up script to validate via 
a different method that's still cryptographically safe: 
<http://mwh.geek.nz/files/gobo/HopValidate>.
> 
> In the screenfuls of stuff that followed 'Compile Nvidia' there were many
>  red Conflict: Programs/blah/blah/blah/something.h lines. I assumed this
>  was to be expected, given that it carried on regardless.
Nvidia replaces several files from X with its own copies. The recipe is 
configured to make sure the links go into place; in most cases where you see 
those conflict warnings that won't happen. You'll need to decide which version 
you want to use in that case, and whether it matters at all (usually, it 
doesn't, but you have to apply some judgement).

Nvidia may need a newer X to work with anyway, so you'd need to upgrade that 
first. I'm not certain about that I believe the newer drivers do work with Xen 
kernels though.
> It eventually stopped with a complaint that one of the packages required a
>  more recent version of Compile.
> 
> Tried 'InstallPackage Compile' - no joy. Tried 'Compile Compile', which
>  eventually stopped with a complaint that I needed a more recent version of
>  Scripts. Tried 'InstallPackage Scripts' - no joy. Tried 'Compile Scripts',
>  which eventually terminated with a complaint that I needed a more recent
>  version of Compile.
Rule of thumb: you never, ever, ever, want to use `Compile {Scripts,Compile}`. 
Unless you do.

One of the package mirrors dropped out, and I think it was the default in 
014.01 (or one of them; the other is spotty too). You can fetch the packages 
directly from gobolinux.org and install from the files, and you can add 
"http://gytha.org/gobo/packages/official/" to GetAvailable.conf to use the 
replacement. kundor.org should still be good most of the time too.
> 
> Spotted 'Perl-something-something' in the output described as a
>  prerequisite for updating Scripts. Tried Compile on it and eventually got
>  a dependency on a more recent version of Glibc. Assumed it was OK to just
>  go ahead and install it, given the promise that multiple versions can live
>  side-by-side :)
> 
> After more compilation guff, eventually got a red line that I had seen
>  previously when a downloaded package is the same version as an installed
>  package, this time relating to Glibc. All the messages after that point
>  were segfaults, and the system was unable to spawn new processes - a state
>  I had never seen before :). A busybox-like shell with compiled-in versions
>  of essential commands might have been useful at this point ...
Static setuid busybox can resolve any problem with the system. You can build 
it from the recipe; the recent versions are safe to have setuid #0.
> My Gobo partition no longer boots (unsurprisingly!), but instead of just
>  reinstalling over it, I would like to first endeavour to fix it, as a
>  learning exercise.
Use RescueSymlinkProgram (n.b. not SymlinkProgram) from a LiveCD or another 
distribution; it's statically-linked so it works with broken libc or from 
another system. You won't be able to chroot in for that reason, so 
SymlinkProgram itself isn't an option. You can use `ln -sf ...` manually too, 
just remember to use relative paths or they won't resolve in both the host and 
the booted system.

The RSP line will be something like `RescueSymlinkProgram /Programs/Glibc/2.5 
/mnt/point/System/Links`. Once that's done you should be able to boot or 
chroot, and then you should run proper SymlinkProgram on it as well to be 
safe.
-Michael
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 835 bytes
Desc: This is a digitally signed message part.
URL: <http://lists.gobolinux.org/pipermail/gobolinux-users/attachments/20100131/58a8c6a5/attachment.pgp>


More information about the gobolinux-users mailing list