[gobolinux-users] My GoboLinux experience thus far

Rehan rehan.khan at dsl.pipex.com
Sun Jan 31 13:23:50 NZDT 2010


(I've also read Michael's and Salvatore's reply)
 
John has some fair points. It shouldn't be this hard to get going with
Gobo. The main gobo website gives the impression that it's all a really
great idea and that if you just take the time to see how things work
(because it's a bit different from other Linux) it's oh so easy to get
going with gobo. The reality is quite a bit different.
 
My initial experience was very painfully similar but it took me a bit
longer to trash my install by some package pulling in glibc during a
Compile operation. Although I soldiered on for a while, eventually the
amount of random, unintuitive arcane knowledge that one needs to know to
do some quite simple things (like add the dhcpd-gui package to the
latest version of dhcpd IIRC) in Gobo just became overwhelming and I
yearned for the good old Fedora days (The 'good old' bi-annual Fedora
re-installs, in fact, had driven me to Gobo in the first place, a few
years of that and it becomes old).
 
It also looks like John hasn't tried to update X windows/kde yet which
is another minefield of specialised handling and after the fact caveats.
I have seen the same stuff come up over and over with new users to Gobo
in the short time I have been following this distro.
 
One of the problems I see is that there is the view that apparently the
0.15 release is somehow going to magically fix some of these things.
Perhaps it will but I find this quite hard to believe (although I'm sure
Jonas/Michael/whoever else is hacking on this might be able to pull that
fat old rabbit out of the hat). It seems to me that 0.15 might not be
the iterative improvement one might think it's going to be but a whole
new kettle of fish due to the significant changes/improvements that seem
to be needed let alone the new features that are envisioned.
 
Personally I would like to see someone more experienced/knowledgeable
than me produce an updated 0.14 cd that just (mostly?) works. A glibc
greater than 2.8 or ideally 2.10 would be sufficient to solve a lot of
problems (if only to get a newer version of udev working). Alternatively
that can be stated as 'what needs to be done to update the 0.14 cd to
kde4 and work on modern hardware?'. A few glitches here and there are
fine but this pain is just.. just.. ... too painful! I had a go at
hacking on this cd and came up against too many 'chicken or egg?'
problems (err... I mean circular dependencies) to make much progress and
finally had to bail due to lack of time (after a lot of time was already
spent).
 
I'm sure some people have been able to go from a vanilla 0.14 install to
the packages that are recent/latest in the repository but I haven't and
not for lack of trying. (btw if you have could you document the process,
I will be eternally grateful).
 
Well aside from the moaning the question I have, is, what actually needs
to be done to get an updated 0.14 cd pushed out so that 0.14 works as
advertised on the gobo website? There are too many new
packages/requirements in the repository to consider the original 0.14 cd
viable (IMHO). Lets get past the 'if you're not a Linux god then wait
for the 0.15 release', 'oh, ok when's the 0.15 release coming?', 'when
it's ready', 'oh, ok any idea when that will be?', ' when it's done.',
'oh, ok, I'll check back in a few then'. It would be great to get
something workable in the interim.
 
thanks for reading this far!
 
Rehan.
 
 
 
________________________________

From: gobolinux-users-bounces at lists.gobolinux.org
[mailto:gobolinux-users-bounces at lists.gobolinux.org] On Behalf Of John
Askme
Sent: 30 January 2010 12:31
To: gobolinux-users at lists.gobolinux.org
Subject: [gobolinux-users] My GoboLinux experience thus far


Hi all

Warning: lengthy ramble ahead.

First time poster here - please let me know if I'm posting in the wrong
place!

Overall Linux experience (~2 years):

Cygwin -> Ubuntu/Wubi -> Ubuntu/native -> Arch -> Ubuntu + Arch +
will-try-anything

Before discovering Ubuntu/Wubi, I seriously considered Gobo as my first
distro, though I now realise that would have been a big mistake :).

Gobo experience thus far:

Installation went smoothly. Console font/colours were beautiful!
Installer didn't offer to use an existing swap partition - a minor
quibble. Was a bit disappointed that 'gobo' wasn't offered as the
default admin account name - I had to type it myself (the default was
'root').

Didn't like the grub splash screen, because it (apparently) didn't offer
to drop to the grub console, which can be useful when I occasionally
accidentally reboot instead of shutdown, or need to manually chainload
etc. Easily disabled though, so just a minor quibble.

Had a nose around the system and liked it. Was mildly disappointed to
see that the links in System/Links/Executables etc don't go through
Programs/Pkg/Current, but point directly to a particular version.
Assumed there was a good reason for this (not just 'efficiency').

Very nice default manpage viewer, by the way.

I realise now that I was a bit too blase about things - I had no idea
how broken stuff could get :). I'll be more careful next time.

First thing I tried to do was install the NVidia driver. Having now seen
the oddly-named 'Afterboot' page in the Wiki (which isn't linked from
the install page, incidentally), I realise that this was a mistake. Next
time I will just do without it (I'd rather play with Xen anyway).

In the screenfuls of stuff that followed 'Compile Nvidia' there were
many red Conflict: Programs/blah/blah/blah/something.h lines. I assumed
this was to be expected, given that it carried on regardless.

It eventually stopped with a complaint that one of the packages required
a more recent version of Compile.

Tried 'InstallPackage Compile' - no joy. Tried 'Compile Compile', which
eventually stopped with a complaint that I needed a more recent version
of Scripts. Tried 'InstallPackage Scripts' - no joy. Tried 'Compile
Scripts', which eventually terminated with a complaint that I needed a
more recent version of Compile.

Spotted 'Perl-something-something' in the output described as a
prerequisite for updating Scripts. Tried Compile on it and eventually
got a dependency on a more recent version of Glibc. Assumed it was OK to
just go ahead and install it, given the promise that multiple versions
can live side-by-side :)

After more compilation guff, eventually got a red line that I had seen
previously when a downloaded package is the same version as an installed
package, this time relating to Glibc. All the messages after that point
were segfaults, and the system was unable to spawn new processes - a
state I had never seen before :). A busybox-like shell with compiled-in
versions of essential commands might have been useful at this point ...

By the way, I did all this from my 'normal user' account, created during
installation, without ever using 'sudo'. Checking the 'admin' box gave
me a whole lot more than just 'sudo' :)

My Gobo partition no longer boots (unsurprisingly!), but instead of just
reinstalling over it, I would like to first endeavour to fix it, as a
learning exercise.

Thank you for reading! To be continued ...

John
   
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.gobolinux.org/pipermail/gobolinux-users/attachments/20100131/b9bd9f18/attachment.htm>


More information about the gobolinux-users mailing list