[gobolinux-users] New install - boot, 'startx', freeze.

Mark Filipak markfilipak.linux at gmail.com
Thu Apr 2 20:26:02 NZDT 2015


Hi Lucas,

There's been a development.

I booted to the live CD and this time I was able to find and install the
VBox Guest Addtions. I can tell that the install worked because mouse
integration worked -- I could drag the mouse into & out of the VM
without having to hit the guest home key (right-ctrl).

With the VBox Guest Additions installed, I then installed Gobo fresh
with reformat.

What's new:
Whereas when I booted previously and submitted "startx" I got a large
gray window with only an immovable mouse cursor in the center, now when
I submit "startx" I stay at a command line, and I get this response:
=====
root at NewMachine ~]startx
xauth:  file /Users/root/.serverauth.1229 does not exist

/usr/bin/X: error while loading shared libraries: libnettle.so.4: cannot
open shared object file: No such file or directory
xinit: giving up
xinit: unable to connect to X server: Network is unreachable
xinit: server error
root at NewMachine ~]_
=====
'/Users/root/' has 9 dotted file & 7 dotted directories & 'Desktop', but
it does not have '.serverauth.1229' (whatever that is).

I can't tell whether this is progress or not.

- Mark.



On 03/31/2015 09:02 AM, Lucas C. Villa Real wrote:
> Hi Mark,
> 
> I'll have to install VirtualBox on my side to reproduce the problem.
> This week is a very busy one for me, but I will do my best to give you
> some advice on how to work around that issue soon.
> 
> Lucas
> 
> On Mon, Mar 30, 2015 at 10:30 AM, Mark Filipak
> <markfilipak.linux at gmail.com <mailto:markfilipak.linux at gmail.com>> wrote:
> 
>     Hey Lucas,
> 
>     In addition to what I wrote below (especially see the end of this
>     message == end of previous message), I have this:
>     =====
>     lspci
>     00:00.0 Host bridge: Intel Corporation 440FX - 82441FX PMC [Natoma]
>     (rev 02)
>     00:01.0 ISA bridge: Intel Corporation 82371SB PIIX3 ISA
>     [Natoma/Triton II]
>     00:01.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE
>     (rev 01)
>     00:02.0 VGA compatible controller: InnoTek Systemberatung GmbH
>     VirtualBox Graphics Adapter
>     00:03.0 Ethernet controller: Intel Corporation 82540EM Gigabit Ethernet
>     Controller (rev 02)
>     00:04.0 System peripheral: InnoTek Systemberatung GmbH VirtualBox Guest
>     Service
>     00:05.0 Multimedia audio controller: Intel Corporation 82801AA AC'97
>     Audio Controller (rev 01)
>     00:06.0 USB controller: Apple Inc. KeyLargo/Intrepid USB
>     00:07.0 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 08)
>     00:0d.0 SATA controller: Intel Corporation 82801HM/HEM (ICH8M/ICH8M-E)
>     SATA Controller [AHCI mode] (rev 02)
>     -----
>     The above matches what 'lspci' outputs in my Linux Mint VM (which works
>     fine).
>     BTW, I'm running the latest VirtualBox.
>     I don't want to give up on Gobo, but I'm pretty clueless. - Mark.
>     =====
> 
>     On 03/26/2015 10:44 PM, Lucas C. Villa Real wrote:
>     -snip-
>     > The thing about Gobo trying to sniff out the VM is because Xorg's
>     > automatic configuration either hangs when probing certain drivers or
>     > produces settings that will not work when the host is under QEMU (at
>     > least that is what my experience has shown). For that reason, we ship a
>     > default xorg.conf that QEMU deals with just fine.
> 
>     "...default xorg.conf" ?????
> 
>     dingdingdingdingdingdingdingdingding
> 
>     I installed Gobo all 3 ways. I kept notes. The following is from my
>     notes:
>     =====
>     Original '/System/Settings/X11/xorg.conf'...
> 
>     -- Selecting the "Base" package doesn't install X, so
>     '/System/Settings/X11/' is empty.
> 
>     -- Selecting the 'Typical' package doesn't install
>     '/System/Settings/X11/xorg.conf'.
> 
>     -- Selecting the 'Full' package doesn't install
>     '/System/Settings/X11/xorg.conf'.
>     =====
>     Bottom line: Unless I create 'xorg.conf', it doesn't exist.
> 
>     > Now, I remember facing a similar problem before: the mouse would just
>     > not work on QEMU for some weird reason. However, I noticed that by
>     > forcing Udev to get device events from the kernel one more time
>     > ("udevadm trigger"), the input device would then be discovered.
> 
>     Ahhhh.... I remember something similar in VMware many years ago. It was
>     not sniffing the VM. It was sniffing the (virtualized) hardware. Lord...
>     I can't remember the details. All I remember is that a VMware client
>     needed to do some sort of mojo to get the (virtualized) hardware to
>     work. VMware eventually was able to fix that at the virtual end instead
>     of at the OS-driver end, but I can't remember how they did it.
> 
>     > Two simple things that you can do are:
>     > 1) type 'udevadm trigger' in the console
>     > 2) type 'gpm -m /dev/input/mice -t imps2' and check that the cursor
>     > moves in the console
> 
>     Re #1: What's supposed to happen?
>     Re #2: The tty console has no mouse, so how can I move it?
> 
>     I did the 2 steps above and took a screen shot here:
>     http://markfilipak.com/GoboLinux.png
> 
>     The cursor didn't do anything special.
> 
>     _______________________________________________
>     gobolinux-users mailing list
>     gobolinux-users at lists.gobolinux.org
>     <mailto:gobolinux-users at lists.gobolinux.org>
>     http://lists.gobolinux.org/mailman/listinfo/gobolinux-users
> 
> 
> 
> 
> -- 
> Lucas
> "If you're looking for a reason I've a reason to give: pleasure, little
> treasure"
> 
> 
> _______________________________________________
> gobolinux-users mailing list
> gobolinux-users at lists.gobolinux.org
> http://lists.gobolinux.org/mailman/listinfo/gobolinux-users
> 


More information about the gobolinux-users mailing list