[gobolinux-users] 'startx' partly fails + corrupt zsh history file

Mark Filipak markfilipak.linux at gmail.com
Sun Apr 5 15:48:10 NZST 2015


On 04/04/2015 08:29 PM, Lucas C. Villa Real wrote:
> On Sat, Mar 28, 2015 at 3:19 PM, Mark Filipak
> <markfilipak.linux at gmail.com <mailto:markfilipak.linux at gmail.com>> wrote:
> 
>     Two questions:
> 
>     1, My new installation boots to a command line. Is that usual? (Note
>     that submitting 'startx' at the command line results in a switch to a
>     uniformly gray screen that has an immovable mouse cursor at its center,
>     but that otherwise is empty.)
> 
>     2, After I login, I see a line that says "zsh: corrupt history file
>     /Users/root/.cache/zsh_history". Is this something that should concern
>     me? (Note that this first appeared upon reboot following an attempt to
>     submit "Compile WindowMaker" as suggested by Lucas (which ended with an
>     error).)
> 
>     Supporting Info:
>     The Gobo installation is into a VirtualBox virtual machine. The VM has
>     drivers, called "Guest Additions", on a CD ISO image,
>     'VBoxGuestAdditions.iso', that is mounted in the VM. The CD is
>     electronically labeled "VBOXADDITIONS_4.3.26_98988". Running a shell
>     script, '/VBoxLinuxAdditions.run', on that CD may help the situation.
>     However, from the Gobo command line, "ls /Mount/CD-ROM" returns nothing.
> 
>     I have about 3200 more questions and problems, but I'd like to start
>     small. :-)
> 
> 
> Hi Mark,
> 
> Today I installed VirtualBox-OSE 4.3.26 and attempted to boot the
> LiveCD. All went fine: mouse works and Enlightenment is loaded as expected.

I'm sorry. I've apparently not made it clear that "new installation"
means GoboLinux installed into the virtual machine. I've never had
problems with booting to the live CD.

> My VM settings are set as:
> 
> System
>   Operating system: other Linux (32-bit)
>   Acceleration: VT-x/AMD-V, Nested Paging, PAE/NX
> 
> Display:
>   Video memory: 32MB
>   Remote desktop server: Disabled
>   Video capture: disabled
> 
> Storage:
>   IDE primary master: [CD/DVD] GoboLinux-015-i686.iso
>   IDE secondary master: empty
> 
> Other than that, I've enabled the Serial port and the USB controller.
> USB 2.0 (EHCI) is disabled. The kernel modules have also been loaded by
> calling '/etc/init.d/vboxdrv start' on the host.
> 
> Hope this helps somehow.
> Lucas

Thank you, Lucas. Did you attempt to actually install Gobo, or did you
stop at booting the live CD?

Happy Easter to all who celebrate Easter tomorrow.


More information about the gobolinux-users mailing list