[gobolinux-users] follow up on 'evaluation' of Gobo Linux 016.01 - second edition ( try )

Lucas C. Villa Real lucasvr at gobolinux.org
Mon Mar 20 15:38:09 NZDT 2017


On Thu, Mar 16, 2017 at 4:10 PM, sali <sali at xs4all.nl> wrote:

> Hello You All,
>
> The new .iso is working quite well for me.
> There were no problems when compiling
> S-Lang and M(idnight)C(ommander) on the Live System ...
>
> Sadly I - have to - think either I am doing something wrong
> or might be there are several 'holes' - in time ? - in the parsing of
> scripts,
> settings and Recipes (Resources/{Dependencies,and Others}).
>
> Trying to Compile PyGobject -> PyCairo the problem of python versions
> arises in all it's 'glamour': while Compile and Scripts need
> python2.7 -> python, the present PyCairo needs python >= 3.2.1
> Then the build 'bailes out'.
>
> And leaves me with this last remark.
> Compile: Your Scripts package is too old. Please update it by running
> ''InstallPackage Scripts''
>
> Trying to get more information I used
> Compile --debug PyCairo 2>&1 | tee logboek/debug_compile.log
>
> Part of the log below in Runner_removals attachment.
>
> Changing the Dependencies left the same result.
> As if the versioning did not matter ( only for Glibc )
> for python.
>
> Seems python3 conflicts with python2.
>

Hi Martin,

I have spotted the problem here and will be including a fix for it on
016.01-beta (to be released this week).


> I spent a day on a dynamic 'python' ( System/Index/bin/python ) script
> like gentoo - used to - have for auto conf / make / others but no usable
> results - yet.
>
> By the way:
> the 'debugging practices' showed me how nice this 'System'*1 actually
> works.
> Quite well. And a lot left to 'learn'.
>

Glad to know that you're liking it :-)

For me.
>
> Time to say "Tot Later"*2
>
> Martin.
>
> *1 Gobo Linux
> *2 Dutch for "Untill later time"
>
>
Best regards,
Lucas
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.gobolinux.org/pipermail/gobolinux-users/attachments/20170319/bf779525/attachment.html>


More information about the gobolinux-users mailing list