Hi,<br><br><br><div><span class="gmail_quote">On 11/24/06, <b class="gmail_sendername">Jonas Karlsson</b> &lt;<a href="mailto:jonka750@student.liu.se">jonka750@student.liu.se</a>&gt; wrote:</span><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
On Tue, 14 Nov 2006 04:17:42 +0100, Martin O.B. &lt;<a href="mailto:martinobal@gmail.com">martinobal@gmail.com</a>&gt;<br>wrote:<br>&gt;</blockquote><div><br><br></div><br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
Just recently read an article/discussion about OpenSSL vs GnuTSL<br>(<a href="http://curl.hostingzero.com/legal/distro-dilemma.html">http://curl.hostingzero.com/legal/distro-dilemma.html</a>), which made me<br>read some parts of the GPL
<br>(<a href="http://www.fsf.org/licensing/licenses/gpl.html">http://www.fsf.org/licensing/licenses/gpl.html</a>) more thoroughly and one<br>thing that caught my eye was the end of section 3. Section 3 reads that if<br>one distributes binaries in any form it should always come with the
<br>source. The end section says that if one makes the binaries available for<br>download it suffices to make the sources available for download from the<br>same place. Does this mean that we actually have to have a source repo or
<br>is it enough to point to where the user can get the code?</blockquote><div><br>In Gobolinux this requirement is especially irrelevant, since it has a policy of not touching the sources of each original project, so it's each project's managers who do or do not comply with the GPL. Gobo patches and recipes are, of course, available in source.
<br><br>&nbsp;</div><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;"><br>&gt;<br>I guess you're saying that you want a version limit for dependencies so
<br>that one doesn't upgrade to far and break apps. This is possible with<br>CheckDependencies, which André already said (but I thought I might clarify<br>:) )</blockquote><div><br>&nbsp;</div></div>Well, yes, but I was concerned about dependency descriptions themselves, as I told Hisham:
<br><a href="http://www.wotfun.com/pipermail/gobolinux-users/2006-November/003989.html">http://www.wotfun.com/pipermail/gobolinux-users/2006-November/003989.html</a><br>So, CheckDependencies is great, but for it to be really useful, versionless dependencies have to be forbidden in Gobolinux.
<br><br>--Martin<br><br>